实力机构合作建仓,2-5个交易日收益10%以上,QQ:352095349,微信:hzxin987

MACD二次金叉选股指标

2019-03-29 10:23栏目:通达信

一、通达信MACD二次金叉选股公式
二、大智慧MACD二次金叉选股公式
三、MACD二次翻红选股公式

所谓MACD连续二次翻红是指MACD第一次出现红柱后,还没有等红柱缩短变绿便再次放大其红柱,这是利用MACD选强势股的关键,也是介入的最佳买点。特别是前期下跌时间长、下跌幅度大的个股,一旦出现“MACD连续二次翻红”形态,股价企稳回升的概率较大。如某只股票的股价开始缓慢回升,MACD由绿变红,一段时间后股价再度下探,红柱又开始缩短至零轴附近,红柱又翻红并逐渐伸长,这便是“MACD连续二次翻红”,也是最佳的买点。在第一次翻红后,红柱开始缩短,越短越好,最好不要超过0轴的第一横线;成交量由萎缩逐渐放大,特别是在二次翻红后,若能得到成交量的配合,该股后市向上冲击的力量会更大。


一、通达信MACD二次金叉选股公式:
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

二、大智慧MACD二次金叉选股公式:
{XG二次金叉}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {选股设JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
a:=if(CROSS(0,dea),1,0);
a1:=if(diff<0 and CROSS(diff,dea),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
jc:IF(SSS-SSB=2 AND SSS>REF(SSS,1),10,0)


三、MACD二次翻红选股公式

所谓MACD连续二次翻红是指MACD第一次出现红柱后,还没有等红柱缩短变绿便再次放大其红柱,这是利用MACD选强势股的关键,也是介入的最佳买点。特别是前期下跌时间长、下跌幅度大的个股,一旦出现“MACD连续二次翻红”形态,股价企稳回升的概率较大。如某只股票的股价开始缓慢回升,MACD由绿变红,一段时间后股价再度下探,红柱又开始缩短至零轴附近,红柱又翻红并逐渐伸长,这便是“MACD连续二次翻红”,也是最佳的买点。在第一次翻红后,红柱开始缩短,越短越好,最好不要超过0轴的第一横线;成交量由萎缩逐渐放大,特别是在二次翻红后,若能得到成交量的配合,该股后市向上冲击的力量会更大。

依据上面的法则以及“MACD二次翻红”的形态,从MACD二次翻红找起涨点入手编写指标如下: 
应大家要求现将原码制作如下: 
{macd二次翻红选股原码} 
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26); 
DEA:=EMA(DIFF,9); 
MACD:=2*(DIFF-DEA); 
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4); 
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1; 
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1); 
FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018; 
FH5:=FH1 AND FH2 AND MACD<0.10; 
FH3 OR FH4 OR FH5;

四、MACD在零轴下二次金叉副图公式
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;